We have resolved the issue affecting NetSuite Service in CA Toronto.
Customer Impact: Customers may have experienced a degradation of service when using NetSuite Service.
If you are still experiencing issues, please contact NetSuite Customer Support through your standard method.
Start Time: 2025-10-28T19:30:11.154000+00:00 End Time: 2025-10-28T21:57:52.882000+00:00
Posted Oct 28, 2025 - 22:00 UTC
Update
We have identified the issue affecting NetSuite Service in CA Toronto. A fix is is still in progress.
Customer Impact: Customers may experience a degradation of service when using NetSuite Service.
Posted Oct 28, 2025 - 21:33 UTC
Update
We have identified the issue affecting NetSuite Service in CA Toronto and the team is working on the fix.
Customer Impact: Customers may experience a degradation of service when using NetSuite Service.
Posted Oct 28, 2025 - 20:53 UTC
Update
We have identified the issue affecting NetSuite Service in CA Toronto and are still actively preparing a fix.
Customer Impact: Customers may experience a degradation of service when using NetSuite Service.
Posted Oct 28, 2025 - 20:25 UTC
Update
We have identified the issue affecting NetSuite Service in CA Toronto and a fix is being prepared.
Customer Impact: Customers may experience a degradation of service when using NetSuite Service.
Posted Oct 28, 2025 - 20:23 UTC
Update
We have identified the issue affecting NetSuite Service in CA Toronto and are still actively preparing a fix.
Customer Impact: Customers may experience a degradation of service when using NetSuite Service.
Posted Oct 28, 2025 - 20:21 UTC
Identified
We have identified the issue affecting NetSuite Service in CA Toronto.
Customer Impact: Customers may experience a degradation of service when using NetSuite Service.
Posted Oct 28, 2025 - 19:49 UTC
Investigating
We're investigating an issue affecting the NetSuite service in CA Toronto. Further details will be provided shortly.
Customer Impact: The current scope and nature of the event are unknown at this time.
Posted Oct 28, 2025 - 19:32 UTC
This incident affected: Application UI (CA Toronto), Asynchronous Services (CA Toronto), Email (CA Toronto), SuiteAnalytics Connect (CA Toronto), SuiteAnswers (CA Toronto), SuiteCommerce Checkout (CA Toronto), SuiteCommerce Webstore / In-Store (CA Toronto), and SuiteTalk (CA Toronto).