We have resolved the issue affecting the NetSuite Service in US Ashburn and US Phoenix.
Customer Impact: Customers may have experienced a degradation of service when using the NetSuite Service including login.
If you are still experiencing issues, please contact NetSuite Customer Support through your standard method.
Start Time: 2025-09-10T17:30:00+00:00 End Time: 2025-09-10T21:05:00+00:00
Posted Sep 10, 2025 - 22:05 UTC
Update
We are applying a fix to alleviate the issue affecting the NetSuite Service in US Ashburn and US Phoenix. Some customers in US Phoenix are starting to experience service recovery, and we are continuing to monitor mitigation progress.
Customer Impact: A subset of customers may experience a degradation of service when using the NetSuite Service in US Ashburn.
Posted Sep 10, 2025 - 20:25 UTC
Monitoring
We are applying a fix to mitigate the issue affecting the NetSuite Service for a subset of customers in US Ashburn and US Phoenix.
Customer Impact: A subset of customers may experience a degradation of service when using the NetSuite Service including login.
Posted Sep 10, 2025 - 18:32 UTC
Identified
We have identified the issue affecting the NetSuite Service for a subset of customers in US Ashburn and US Phoenix.
Customer Impact: A subset of customers may experience a degradation of service when using the NetSuite Service including login.
Posted Sep 10, 2025 - 17:40 UTC
This incident affected: Application UI (US Ashburn 2, US Ashburn 4, US Ashburn 5, US Ashburn 6).