NetSuite Application UI | Multiple Regions

Incident Report for Oracle NetSuite Service

Resolved

The issue is now resolved. A root cause analysis will be published through the normal process. If you are still experiencing issues, please contact NetSuite Customer Support through your standard method.
Posted Dec 22, 2025 - 20:42 UTC

Update

We are continuing to monitor for any further issues.
Posted Dec 22, 2025 - 20:33 UTC

Update

We are continuing to monitor for any further issues.
Posted Dec 22, 2025 - 19:17 UTC

Update

We are still applying a fix to alleviate the issue affecting NetSuite Application UI in Multiple Regions. Some customers are starting to experience service recovery, and we are continuing to monitor mitigation progress.

Customer Impact: Customers may experience a degradation of service when using NetSuite Application UI.

Posted Dec 22, 2025 - 15:00 UTC

Update

We are still applying a fix to alleviate the issue affecting NetSuite Application UI in Multiple Regions. Some customers are starting to experience service recovery, and we are continuing to monitor mitigation progress.

Customer Impact: Customers may experience a degradation of service when using NetSuite Application UI.

Posted Dec 22, 2025 - 13:59 UTC

Monitoring

We are applying a fix to mitigate the issue affecting NetSuite Application UI in Multiple Regions.

Customer Impact: Customers may experience a degradation of service when using NetSuite Application UI.

Posted Dec 22, 2025 - 13:00 UTC

Identified

We have identified the issue affecting NetSuite Application UI in Multiple Regions.

Customer Impact: Customers may experience a degradation of service when using NetSuite Application UI.

Posted Dec 22, 2025 - 12:00 UTC

Monitoring

We are applying a fix to mitigate the issue affecting NetSuite Application UI in Multiple Regions.

Customer Impact: Customers may experience a degradation of service when using NetSuite Application UI.

Posted Dec 22, 2025 - 11:23 UTC

Update

We're still investigating an issue affecting NetSuite Application UI in Multiple Regions.

Customer Impact: Customers may experience a degradation of service when using NetSuite Application UI.

Posted Dec 22, 2025 - 10:24 UTC

Investigating

We're investigating an issue affecting the NetSuite service in Multiple Regions. Further details will be provided shortly.

Customer Impact: The current scope and nature of the event are unknown at this time.

Posted Dec 22, 2025 - 09:57 UTC
This incident affected: Application UI (EU Amsterdam 1, UK Newport, AP Osaka, CA Montreal, EU Amsterdam 2, AP Hyderabad, AP Mumbai).