NetSuite Service | Multiple Regions

Incident Report for Oracle NetSuite Service

Resolved

We have resolved the issue affecting the NetSuite service impacting login for a subset of customers in multiple regions.

Customer Impact: Affected customers may have been unable to log in or experienced a degradation of service.

If you are still experiencing issues, please contact NetSuite Customer Support through your standard method.

Start Time: 2025-05-27T05:07:03+00:00
End Time: 2025-05-27T08:05:57+00:00
Posted May 27, 2025 - 08:06 UTC

Update

We are continuing to investigate this issue.
Posted May 27, 2025 - 07:43 UTC

Update

We are executing the necessary mitigation steps to restore service impacting login for a subset of customers in multiple regions.

Customer Impact: Affected customers may be unable to log in or may experience a degradation of service.
Posted May 27, 2025 - 07:36 UTC

Update

We are executing the necessary mitigation steps to restore service impacting login for a subset of customers in multiple regions.

Customer Impact: Affected customers may be unable to log in or may experience a degradation of service.
Posted May 27, 2025 - 07:34 UTC

Update

We are executing the necessary mitigation steps to restore service for a subset of customers in multiple regions.

Customer Impact: Affected customers may be unable to log in or may experience a degradation of service.
Posted May 27, 2025 - 07:34 UTC

Update

We have identified an issue affecting the NetSuite service impacting login for a subset of customers in multiple regions. We are working to determine the necessary mitigation steps.

Customer Impact: Affected customers may be unable to log in or may experience a degradation of service.
Posted May 27, 2025 - 06:09 UTC

Investigating

We started investigating an issue which is affecting the NetSuite service in multiple regions. Further details will be provided shortly.
Posted May 27, 2025 - 05:07 UTC
This incident affected: Application UI (UK London, UK Newport, AP Melbourne, AP Sydney, AP Tokyo, US Chicago, AP Hyderabad, AP Mumbai).