We have resolved the issue affecting NetSuite SuiteCommerce in US Ashburn 3.
Customer Impact: Customers may have experienced a degradation of service when using NetSuite SuiteCommerce including Webstore Checkout and Webstore / In-Store.
If you are still experiencing issues, please contact NetSuite Customer Support through your standard method.
Start Time: 2026-01-16T01:53:02.230000+00:00 End Time: 2026-01-16T02:49:20.687000+00:00
Posted Jan 16, 2026 - 02:51 UTC
Identified
We have identified the issue affecting NetSuite SuiteCommerce in US Ashburn 3.
Customer Impact: Customers may experience a degradation of service when using NetSuite SuiteCommerce including Webstore Checkout and Webstore / In-Store.
Posted Jan 16, 2026 - 02:14 UTC
Update
We're investigating an issue affecting NetSuite SuiteCommerce in US Ashburn 3.
Customer Impact: Customers may experience a degradation of service when using NetSuite SuiteCommerce including Webstore Checkout and Webstore / In-Store.
Posted Jan 16, 2026 - 02:14 UTC
Investigating
We're investigating an issue affecting the NetSuite service in Multiple Regions. Further details will be provided shortly.
Customer Impact: The current scope and nature of the event are unknown at this time.
Posted Jan 16, 2026 - 01:57 UTC
This incident affected: SuiteCommerce Checkout (US Ashburn 3) and SuiteCommerce Webstore / In-Store (US Ashburn 3).