NetSuite SuiteProjects Pro | US Ashburn S

Incident Report for Oracle NetSuite Service

Resolved

We have resolved the issue affecting NetSuite SuiteProjects Pro in US Ashburn S.

Customer Impact: Customers may have experienced a degradation of service when using NetSuite SuiteProjects Pro including login.

If you are still experiencing issues, please contact NetSuite Customer Support through your standard method.



Start Time: 2026-05-28T10:06:38.346000+00:00
End Time: 2026-05-28T11:19:21.872000+00:00
Posted May 28, 2026 - 11:23 UTC

Update

We're investigating an issue affecting NetSuite SuiteProjects Pro in US Ashburn S.

Customer Impact: Customers may experience a degradation of service when using NetSuite SuiteProjects Pro including login.

Posted May 28, 2026 - 11:12 UTC

Investigating

We're investigating an issue affecting the NetSuite SuiteProjects Pro in US Ashburn S. Further details will be provided shortly.

Customer Impact: The current scope and nature of the event are unknown at this time.

Posted May 28, 2026 - 10:13 UTC
This incident affected: SuiteProjects Pro (US Ashburn S).